Battery charging problem

everything camper trailers, trips, tips, tricks & mods

Moderators: krp102, Coxy68, robcaz

Post Reply
Aaron G
Posts: 2
Joined: Mon Nov 08, 2021 9:58 pm

Battery charging problem

Post by Aaron G » Thu Nov 11, 2021 7:48 am

Hi, I am on my first trip in my MDC cruiser highside and I am having trouble charging the batteries. I have a powered site and have connected a 15 amp leap to the camper.The inverter is turned on but nothing is happening, the charger power light is not on.

User avatar
robcaz
Posts: 1217
Joined: Sat Oct 12, 2013 4:07 pm
Location: Stockton NSW
Contact:

Re: Battery charging problem

Post by robcaz » Mon Nov 15, 2021 8:11 pm

Hi Aaron,

Is the 240volt powerpoint that the charger is plugged into turned on?
happy camping
Rob & Carol
Australian CamperTrailers Group co-owner


Image
We're just two lost souls swimming in a fish bowl, year after year

Aaron G
Posts: 2
Joined: Mon Nov 08, 2021 9:58 pm

Re: Battery charging problem

Post by Aaron G » Sun Nov 21, 2021 5:43 pm

Hi, Thanks for the reply. I have worked out the problem. The charger was plugged into the inverter ,it now plugged into the power point and all is good.

User avatar
robcaz
Posts: 1217
Joined: Sat Oct 12, 2013 4:07 pm
Location: Stockton NSW
Contact:

Re: Battery charging problem

Post by robcaz » Tue Nov 23, 2021 9:34 am

Hi Aaron,

Something simple, that's good. Thanks for getting back to us.
happy camping
Rob & Carol
Australian CamperTrailers Group co-owner


Image
We're just two lost souls swimming in a fish bowl, year after year

Post Reply